install gef

0x00:

gdb是linux下的调试利器,但无奈界面不太友好,所以需要一些辅助插件。

0x01:

之前我一直使用的是pead,之前了解到还有个插件gef,因为gef支持多构架,而且heap的分析功能简直是CTF中的神器,所以决定装一波。

0x02: 问题

在按照官方文档安装之后,一直提示有些模块无法加载,是因为一些依赖库没安装好

0x04:解决

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
# root at kali in ~ [3:35:23]
$ cd unicorn
# root at kali in ~/unicorn on git:master o [3:35:25]
$ ls
AUTHORS.TXT config.mk include libunicorn.so.1 Makefile README.md uc.d
bindings COPYING LEAK_VALGRIND list.c make.sh samples uc.o
ChangeLog CREDITS.TXT libunicorn.a list.d pkgconfig.mk tests unicorn.pc
config.log docs libunicorn.so list.o qemu uc.c
# root at kali in ~/unicorn on git:master o [3:35:25]
$ cd bindings
# root at kali in ~/unicorn/bindings on git:master o [3:35:27]
$ ls
const_generator.py dotnet go haskell java Makefile msvc python README ruby
# root at kali in ~/unicorn/bindings on git:master o [3:35:28]
$ cd python
# root at kali in ~/unicorn/bindings/python on git:master o [3:35:34]
$ sudo python setup.py install

然后就顺利解决了

0x04:

安装的时候还是建议python3的版本,如果gdb不支持的话,那就只能重新编译了,多多关注gef项目的讨论区

文章目录
  1. 1. 0x00:
  2. 2. 0x01:
  3. 3. 0x02: 问题
  4. 4. 0x04:解决
  5. 5. 0x04:
,